ComputerForum.com ComputerForum.com  

Go Back   Computer Forum > Computer Hardware > Computer Memory and Hard Drives

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-30-2010, 10:13 PM   #1
Byte Member
 
PurpleSnow's Avatar
 
Join Date: Jan 2010
Location: Johannesburg, South Africa
Posts: 87
Default 8gb flash reading 8mb

I got a Kingston 8GB flash drive and something weird is up with it. I was busy with a windows 7 unattended setup that runs from the drive. but after a few failures, I formatted the drive and now it says 8mb....

How do I fix this now... I tried formatting with a few utilities but nothing seems to work.

__________________
Moded HAF 932
ASUS P8P67
I7 2600K
Corsair Vengeance 1600 DDR3
MSI GTX 570
Gigabyte 720w PSU
Logitech G19, Rocat Kova
Dell 26inch LED
Win7 Pro 64bit
PurpleSnow is offline   Reply With Quote
Sponsored Links
Old 09-30-2010, 11:55 PM   #2
Terabyte Member
 
bkribbs's Avatar
 
Join Date: Mar 2010
Location: USA
Posts: 2,340
Default

Have you checked to see if it is maybe partitioned? I would download GParted and try looking at it on there and see what it says. I know I was messing with a Chromium Install, and after the install, my 2 gig flash drive came up as 693 mb. I have to reallocate memory. Which you can do with GParted.
bkribbs is offline   Reply With Quote
Old 10-01-2010, 05:49 PM   #3
Bit Member
 
Join Date: Dec 2008
Posts: 3
Default

Before doing any troubleshooting you should check to see if it is an authentic Kingston drive. There are many counterfeits out there and your problem description is typical of the counterfeits. You can check the authenticity by looking at the metal USB connector that fits into the computer. Kingston laser etches three lines of numbers on one side of the metal connector. If those do not exist then it is not actually made by Kingston and that would explain why it is failing. Sometimes the counterfeiters will use very low capacity flash memory chips inside and program the controller to report to Windows a much larger capacity. This could be why yours now shows as 8MB.

If it is a legit drive then the partition table might have become corrupted. In which case try GParted like bkribbs mentioned. Also there is a free format program that might help. Google HP USB Disk Storage Format. Either of these utilities might correct the problem.

Last resort, call Kingston Tech Support 800-435-0640. If it is an authentic drive they will replace it for you.
techkingston08 is offline   Reply With Quote
Old 10-06-2010, 11:18 AM   #4
Byte Member
 
PurpleSnow's Avatar
 
Join Date: Jan 2010
Location: Johannesburg, South Africa
Posts: 87
Default

ok so I checked for the print on the metal, there aint any. But I searched the serial and it picks up as Kingston, but any case, since it may be generic is there a way still to fix it.

I cant get GParted working can anyone help me out.

I also got a Sony VAIO 16GB and it shows correctly but loses data. Want to try fix it to. So if anyone knows more abt GParted Ill appreciate some help.
__________________
Moded HAF 932
ASUS P8P67
I7 2600K
Corsair Vengeance 1600 DDR3
MSI GTX 570
Gigabyte 720w PSU
Logitech G19, Rocat Kova
Dell 26inch LED
Win7 Pro 64bit
PurpleSnow is offline   Reply With Quote
Old 10-06-2010, 01:27 PM   #5
Terabyte Member
 
MyCattMaxx's Avatar
 
Join Date: Jun 2005
Location: 127.0.0.1
Posts: 3,147
Default

On the one that loses data, it may be that you aren't ejecting properly
__________________
01000111011011110111010000100000010011010110100101 1000110110010100111111

Maxx
MyCattMaxx is offline   Reply With Quote
Old 10-06-2010, 02:35 PM   #6
Byte Member
 
PurpleSnow's Avatar
 
Join Date: Jan 2010
Location: Johannesburg, South Africa
Posts: 87
Default

ive never had any problems like that before but will give it a try.



So anybody have any info for me on GParted.....
__________________
Moded HAF 932
ASUS P8P67
I7 2600K
Corsair Vengeance 1600 DDR3
MSI GTX 570
Gigabyte 720w PSU
Logitech G19, Rocat Kova
Dell 26inch LED
Win7 Pro 64bit
PurpleSnow is offline   Reply With Quote

Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iv just found what was causing the 78c temp reading Drastik Computer Cases, Power Supplies and Cooling 10 08-22-2009 07:15 AM
Looking for USB 2.0 Flash Memory External Hard Drive? Anyone know about this? 2048Megabytes Computer Memory and Hard Drives 4 11-29-2007 01:04 PM
U3 flash drive problems redneckbcer Computer Memory and Hard Drives 2 11-27-2007 04:04 AM
Problems with Flash player (installed or not installed) kiis102 General Computer Chat 0 10-05-2006 02:18 AM
Flash 8 Download problem jtovb General Software 2 09-09-2006 03:21 PM


All times are GMT +1. The time now is 08:55 PM.


Powered by: vBulletin Version 3.8.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0 ©2011, Crawlability, Inc.
Copyright © 2002-2014 Computer Forum