A troublesome Lenovo Z61t laptop...

Discussion in 'Laptops, Tablets and Smartphones' started by linkin, Apr 17, 2010.

  1. linkin

    linkin VIP Member

    Messages:
    13,507
    Okay, my dad won this used laptop off of ebay. First thing i did was ring up microsoft and activate the copy of windows xp. all is fine there. Now, the problems:

    Audio doesn't work - Drivers are isntalled, no sound out of speakers or headphones.

    Bluetooth: Driver install says supported hardware could not be found.

    Wireless: Driver installs successfully (or so it tells me) and the intel wireless manager says driver not installed.

    And lastly, I cannot change the logon method to the welcome screen. Both options are greyed out. It gives me an error:

    "A recently installed program has disabled the Welcome Screen and Fast User Switching. To restore these features, you must uninstall the program. The following file might help you identify the program that made the change: IWPDGINA.DLL"

    I've got no idea what it's for... This laptop was advertised as a fresh install of windows and all drivers installed...

    What i have tried:

    Downloading the latest drivers from the lenovo website.
    Removing all drivers and starting again.

    I'm thinking it's all software issues... can anyone enlighten me? I'm no expert on laptops.

    Lastly, the specs:

    Intel T2500 Core Duo 2.0ghz CPU
    1GB RAM (one DIMM)
    Mobile Intel 945 Express Chipset Family Graphics
    Toshiba MX1032GSX 100Gb Hard Drive
    DVD Burner

    There are 4 things in device manager without drivers:

    BCM2045B (No Idea)
    Ethernet Controller (I'm guessing this is the wireless because the LAN works)
    SM Bus Controller (No Idea)
    Unknown Device (most likely the bluetooth adapter)

    Any help in solving these problems is greatly appreciated! This laptop is going to end up being sent to my step-mum's brother in the philippines, and i have been "contracted" to fix it. ;)

    EDIT: To JohnB35/anyone that knows this, here are the ID's for the things with missing drivers, if you can help me:

    BCM2045B: USB\VID_0A5C&PID_2110\5&35D80910&0&1

    Ethernet Controller: PCI\VEN_168&DEV_1014&SUBSYS_058A1014&REV_01\4&20975680&0&00E1

    SM Bus Controller: PCI\VEN_8086&DEV_27DA&SUBSYS_200F17AA&REV_02\3&B1BFB68&0&0FB

    Unknown Device: ACPI\IBM0068\5&2890D699&0
     
    Last edited: Apr 17, 2010
  2. linkin

    linkin VIP Member

    Messages:
    13,507
    Bump...

    Anyone?
     
  3. linkin

    linkin VIP Member

    Messages:
    13,507
    come on guys, i need to get this thing fixed :)
     
  4. linkin

    linkin VIP Member

    Messages:
    13,507
    bump. audio issue fixed!
     
  5. FunnelWeb

    FunnelWeb New Member

    Messages:
    207
  6. johnb35

    johnb35 Malware and Spam Assassin Staff Member

    Messages:
    32,937
    That error you are getting is referring to the intel pro wireless software and i've read where it causes issues with the login/welcome screen. However, according to your device id for the wireless, you have the wrong driver installed. You have an atheros chip, so try this driver.

    http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70480

    BCM2045B refers to your bluetooth. http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70450

    smbus driver - http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-62939

    unknown device - http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-4gxpeg
     
  7. linkin

    linkin VIP Member

    Messages:
    13,507
    Cheers! Downloading all of them now... I'll try them later. Also, the logon thing was fixed when i created another account.
     
    Last edited: Apr 18, 2010
  8. linkin

    linkin VIP Member

    Messages:
    13,507
    Alright, that did the trick. everything works now :D
     

Share This Page