Invalid IP address

Discussion in 'Computer Networking and Servers' started by dustman, Jan 1, 2011.

  1. dustman

    dustman New Member

    Messages:
    71
    I cannot re-establish wireless access. I have an HP Pavilion DV8125nr Media Center laptop that I have used wirelessly successfully for the last 2 years with my Linksys WRT54G2 wireless G router.I ran into some computer problems that made me have to reinstall Windows XP (the factory original disk had Symantic/Norton on it and since it was expired, I deleted it). Now I get no wireless. I get the error message "Invalid IP", and it comes back with one that starts with 169. When I try to use the "repair IP address" function, it comes back with 0.0.0.0. I saw on Windows help that if you remove Symantic/Norton protection, you have to go to a certain registry key and delete SYMTDI, then you will be fine. I found the key, but that SYMTDI wasn't there. I have tried online suggestions, everybody seems to be having this problem, but none of the solutions seem to work for anybody. I still get the error message "low or no connectivity". Any ideas? I called Comcast (my net provider), they say it is a problem with the router. I contacted Linksys, they say it is out of warranty ,they can't help me, but they don't think it's a router problem anyway. I can't believe i'm having this much trouble. Any help would be greatly appreciated.

    Thanks,

    Dustman
     
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,201
  3. dustman

    dustman New Member

    Messages:
    71
    Thanks, johnb35

    Hello, johnb35,

    Thanks for the response. I downloaded and ran the Norton removal tool, still couldn't connect. I checked in device manager, I had a Broadcom 802.11b/gwlan, I tried to update the driver, it said the device was working properly and the driver in it was the best one for it. I downloaded Belarc, and it gave all of the information, the APIPA address starting with 169, which I am not sure is a valid IP address, as I had seen those starting with 169 are invalid, but I had also seen online that those were Microsoft IP addresses. It showed "Dhcp: none responded". I don't know where to go from here.

    Thanks again,

    Dustman
     
  4. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,201
    Go into network connections in control panel, right click on your wireless connection and click on properties. highlight internet protocol(tcp/ip) and then click on the properties button. make sure the that obtain ip addiress automatically and obtain dns server address automatically are checked.
     
  5. dustman

    dustman New Member

    Messages:
    71
    Hi, again, johnb35,

    Both were already checked "automatically". I did notice it offered me a place to put in an IP address manually. I have an IP address for my ethernet that looks ok, but I don't know if it will let me use that. The one that comes up for wireless is the one that starts with 169., which I think might be an invalid one.

    This really baffles me.

    Thanks for your help, I do appreciate it.

    Dustman
     
  6. A Cheese Danish

    A Cheese Danish New Member

    Messages:
    353
    The 169 address is Microsofts default IP address for when there isn't one issued for your pc.
    Question: Can you connect to the internet via ethernet? Hardwired. (not sure if you are currently using it
    to post, hence why I asked).
     
  7. dustman

    dustman New Member

    Messages:
    71
    Hi, again,johnb35,

    Yes, I can connect with the ethernet, but I have to carry the laptop all the way to the back of the house to hook onto the router, and I use the laptop normally clear at the other end of the house near the kitchen where my work files are. So I can connect hard wired, but not with my wireless router, which I bought for this laptop.

    Thanks,

    Dustman
     
  8. dustman

    dustman New Member

    Messages:
    71
    Hi, A Cheese Danish,

    Thanks for the response, I didn't catch it was from another member, i have only been getting responses from johnb35, and I thought it was from him. Sorry for the mix up! I need all the help I can get! LOL

    Thanks again,

    Dusstman
     
  9. dustman

    dustman New Member

    Messages:
    71
    Ok, all,

    When I opened properties on my wireless, both auto tabs were checked, but there was a line I could choose that would allow me to insert an IP address myself. I had one for the ethernet, so I put that in, and it said I was connected with excellent strength. I let the ethernet one find a new IP address so there would be no conflicts.

    I then unplugged the ethernet cord, my wireless connection said I was connected at full strength, but when I tried to get on the net, I got that dreaded "this page could not be shown" (the same one that opens when you forget to plug your ethernet cord in).

    It seems like we're getting closer, but what in the world could be hanging it up now? Man, this is aggravating!

    Dustman
     
  10. A Cheese Danish

    A Cheese Danish New Member

    Messages:
    353
    dustman.
    I know you checked already in device manager, but try this. Right click the wireless adapter
    and select Uninstall. Then restart your computer and it should find the device. Try that and see if it helps.
     
  11. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,201
    You may also want to check to make sure there isn't a proxy set. Go into internet options in control panel and click on the connection tab, then click on lan settings button, then make sure the boxes under proxy settings are unchecked.
     
  12. dustman

    dustman New Member

    Messages:
    71
    Hi, again, A Cheese Danish,

    I un-installed the wireless device, turned the computer off and back on, and it rediscovered it. I tried to connect to my wireless network, but now it says it cannot connect me because it could not find a CERTIFICATE to log me onto my network. I don't know what that means.

    Any ideas?

    Thanks again,

    Dustman
     
  13. dustman

    dustman New Member

    Messages:
    71
    Hello, again,

    On that proxy thing, the proxy is unchecked on the ethernet connection settings, but I can't find the settings to check off proxy on the wireless.

    Dustman
     
  14. tlarkin

    tlarkin VIP Member

    Messages:
    12,880
    A certificate is part of a security feature that has to do with cryptography. Servers issues a certificate to identify a user or client by issuing them a key from the CA. I really doubt you have this set up in your home, something has been misconfigured or gone awry.


    I would recommend this:

    1) reset your router for factory defaults
    2) Go into router and set up security again, use WPA with AES encryption
    3) reconfigure wireless client to connect to your SSID with proper wireless passkey


    See if that fixes it.
     
  15. dustman

    dustman New Member

    Messages:
    71
    I am ready to chuck this dang box out the window! I have spent hours and hours parked in front of it just trying to get the wireless connection. I have tried fix after fix, and nothing works. I have reset the router to default settings, assigned a new WAP key, wrote it down carefully, was congratulated on a successful installation, and poof! STILL no wireless internet connection! Device manager shows it's working perfectly, and enabled. I would never have believed I would have this kind of trouble with ANYTHING on a computer! Any other ideas? It's probably something really simple, but for the life of me I can't find it. : (

    Dustman
     
  16. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,201
    You said something about a certificate. Try this and see if its set up that way. Go into network connections in the control panel, right click on your wireless connection and click on properties, clkick on the wireless network tab, click on properties toward the bottom, then click on the authentication tab and make sure the "enable IEEE 802.1x authentication for this network is unchecked. It its checked, uncheck it and you should then get internet.
     
  17. dustman

    dustman New Member

    Messages:
    71
    Hi, again,

    I think we might be narrowing it down a bit. That IEEE 802 thing is unchecked (still no iwireless access) but after I had set the router back to defaults and put in a WPA2 key,now there are 2 wireless networks listed (both mine, same name), one was automatic, one was manual. I cannot connect to the automatic, so I tried te manual, it had me put in the WPA2 key, but still wouldn't connect me to the net. But, for the first time, when it called up the list of local wireless networks, it came up with one that was unprotected (not mine). I certainly don't have any bad intentions, but wanted to see if I could connect to ANY network. It wouldn't connect, so it has to be something in my computer, probably a simple setting. Another tiny puzzle piece, but still no cigar.

    Dustman
     
  18. dustman

    dustman New Member

    Messages:
    71
    P.S.

    There is a setting checked in wireless net properties that says let windows configure your internet access. If I uncheck it, the whole page goes blank. Do you think this has inthing to do with any of this?

    Dustman
     
  19. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,201
    Yes, you want windows to manage your wireless connection as you don't need extra software loading at bootup to slow you down. Go back into network connections in the control panel and right click on your wireless connection and click on properties, click on the wireless network tab. Do down to the preferred network box and highlight each network and click on remove. Then click on the advanced button on the bottom and make sure that only "any available network" is checked. Reboot the computer and try connecting to your router again. What I just had you do was to clear your existing connections in case there was an issue there.
     
  20. tlarkin

    tlarkin VIP Member

    Messages:
    12,880
    It sounds to me like your client cannot negotiate an IP with the DHCP server, and thus you are always getting a self assigned IP, the 169.x.x.x. If you cannot even connect to an unsecured network then you have problems.

    I wonder if the radio went bad or is turned off on your card, thus you are getting barely any signal?

    Lets reset your router with zero security, can you connect to it?
     

Share This Page