Please help with my TSSTcorp CD/DVDW TS-H552L drive!

Discussion in 'CD/DVD/Blu-ray Technology' started by racer13fly, Jan 13, 2009.

  1. racer13fly

    racer13fly New Member

    Messages:
    48
    It used to work fine, but suddenly I noticed that something was wrong when I put a disc in and it didn't recognize it. I went to the device manager and here is what I saw:
    View attachment 2864
    I tried reinstalling it, no change. What does this mean? It opens and closes fine. The light blinks whenever a disc is put in. Please help!
    Thanks!
     
    Last edited: Jan 14, 2009
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,314
    Uninstall the drive and then reboot the laptop and see if windows can reinstall the driver correctly.
     
  3. racer13fly

    racer13fly New Member

    Messages:
    48
    it's a desktop, but ok. ill try.
     
  4. racer13fly

    racer13fly New Member

    Messages:
    48
    nope, no change. same thing. It says something about the driver. not installing right. I went to the samsung ODD website, and they dont even have the driver anymore..... they have TS-H552D, but not TS-H552L...
     
  5. racer13fly

    racer13fly New Member

    Messages:
    48
    Last edited: Jan 14, 2009
  6. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,314
    Try doing a repair installation of windows.
     
  7. racer13fly

    racer13fly New Member

    Messages:
    48
    how do I do that?
     
  8. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,314
    Put the install cd in the drive and boot to it. Watch the prompts for when it asks you if you want to do a repair install or fresh install. DO NOT hit R when it asks you if you want to use the recovery console to try to fix it. Repair will be on the next screen you see.
     
  9. racer13fly

    racer13fly New Member

    Messages:
    48
  10. bomberboysk

    bomberboysk Moderator Staff Member

    Messages:
    13,257
    Dont repair, i know whats causing it. Delete your upper and lower filters, i had the same problem numerous times.

    Go down to Advanced Troubleshooting, will tell you what you need to do:
    http://support.microsoft.com/kb/314060
     
  11. racer13fly

    racer13fly New Member

    Messages:
    48
    thanks! it finally works!
     
  12. racer13fly

    racer13fly New Member

    Messages:
    48
    I have another problem..... The disc drive (which IS CD/DVDW) is shown as 2 different drives: ScreenHunter_01 Jan. 14 17.14.jpg
    When I put a CD in, it reads it fine, but if I put a DVD in, it doesn't detect anything on it, on either drives. the only 1 that works is the one that says it's a CD. I tried uninstalling and reinstalling them both at the same time, no change. please help! i'm trying to do something and it's delaying me!
     
  13. racer13fly

    racer13fly New Member

    Messages:
    48
    this is wierd. if I put a DVDw in, things like Magic ISO can still burn and read it. lol. what's up with that?
     
  14. bomberboysk

    bomberboysk Moderator Staff Member

    Messages:
    13,257
    You dont happen to have something like daemon tools lite installed on there do you? That could cause you to have 2 drives show up among other things.
     
  15. sheinemann

    sheinemann New Member

    Messages:
    3
    I have been having the same problem.

    Windows XP recognizes the drive. But, cannot read from ot write to discs in the drive. I have; used HP restore to return the computer to the 'as shipped' state; tried the Miicro$oft fix suggested by bomberboysk. Nothing worked.

    I can however, still burn Ligfhtscribe labels.

    I have just about decided that the read/write laser is toast.
     
  16. racer13fly

    racer13fly New Member

    Messages:
    48
    I found that if you use something like Magic ISO or something like that, it burns anything just fine!
     
  17. sheinemann

    sheinemann New Member

    Messages:
    3
    Doesn't sound like it will work. But hey, I have heard of stranger things. So, I downloaded the latest Magic Iso and gave it a try. No Dice. It sees the drive. But thinks the drive is alway empty.
     
  18. tracy.holt

    tracy.holt New Member

    Messages:
    1
    Thank you

    I want to thank bomberboysk, i haven't had the problem for quite sometime and couldn't remember how to fix it, I read your post clicked on the link and it was way more simpler than I remember.
    Thank you so much for the Link.
    Tracy Holt
     

Share This Page