Problems with running The Witcher 2

Discussion in 'Video Cards and Monitors' started by megamouth, Jul 5, 2011.

  1. megamouth

    megamouth New Member

    Messages:
    5
    I bought The Witcher 2, and I assumed I could run it. But when I load it, the framerate chugs terribly. I am running this on a laptop.

    Here are my specs:
    HP Pavillion Notebook dv7t Quad-Edition
    Windows 7 64-bit
    Intel Core i7-2720QM (2.2GHz/turbo-boost to 3.3GHz, 6MB L3 cache)
    2GB GDDR5 Radeon HD 6770M
    6GB DDR3 System Memory
    750GB 7200RPM Hard drive

    And here are the minimum requirements for The Witcher 2:
    Intel Core 2 Duo 2.2 GHz or AMD 2.5 GHz equivalent
    Memory: 2 GB for Windows Vista and Windows 7
    Hard drive: 16GB of free space
    Graphics Card: DirectX 9.0c: Nvidia GeForce 8800, 512 MB memory or ATI HD3850 512 MB
    Sound Card: DirectX 9.0c

    I asked around before here, and I was told that I should be able to run it, but maybe I should update my graphics drivers. I did, and the framerate still chugs. Also, I went to http://www.systemrequirementslab.com/cyri/ (aka Can You Run It?) and it said I could not run it, but again, this contradicts what I have been told.

    So, should I be able to run it, or should I just return the game? Any help is appreciated, thank you.
     
  2. diduknowthat

    diduknowthat formerly liuliuboy

    Messages:
    9,268
    What settings are you running it at? Try lowering it to the minimum settings at native resolution and see if that helps. The Witcher 2 is a very demanding game.
     
  3. Cromewell

    Cromewell Administrator Staff Member

    Messages:
    14,367
    What settings are you trying to run the game at? Your system exceeds the minimum requirements. Does it chug all the time or just in certain situations?
     
  4. megamouth

    megamouth New Member

    Messages:
    5
    I am running it on the lowest possible settings, I lowered them all after it intially froze from running on medium settings. And yes it chugs all the time, the intro cutscenes were terribly slow and the tutorial gameplay is barely playable.
     
  5. diduknowthat

    diduknowthat formerly liuliuboy

    Messages:
    9,268
    Are you playing with AC plugged in? Make sure your power setting is set to performance mode instead of power saver.

    edit: wooo 9000th post!
     
    Last edited: Jul 5, 2011
  6. claptonman

    claptonman New Member

    Messages:
    5,481
    What component did system requirements say that wouldn't be able to run it? And did you remove the old drives for the laptop? Any background processes running? How hot does your CPU and GPU get to when you play the game?
     
  7. megamouth

    megamouth New Member

    Messages:
    5
    Yes it is high performance mode, and I haven't had it running long enough for it to heat up.

    But I don't think I've removed any old drivers, how would I go about doing that? Maybe that's the problem.
     
  8. claptonman

    claptonman New Member

    Messages:
    5,481
    I'm used to desktops so it might be different.
    First, download the new video drivers, if you since deleted them. Make sure you find the correct drivers. I searched for them and got this:

    http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-64.aspx#1

    Under "Individual downloads." That driver is for all ATI HD 6xxxM cards for Win 7 64-bit. That should be the right one.

    On your add/remove programs, there should be an item called ATI catalyst Install Manager.
    Click it and press change. Go through the process and completely uninstall everything.
    Restart.
    Install the new drivers.
    And restart again.
     
  9. megamouth

    megamouth New Member

    Messages:
    5
    Well I uninstalled and restarted, then reinstalled and restarted, and it still runs slow. Also, to respond to your first question, system requirements said that the only component that would not be able to run it was my video card, saying this:

    Minimum: 512 MB RAM, supporting Pixel Shader 3.0 (NVIDIA GeForce 8800 or ATI Radeon HD 3850)
    You Have: Mobile Intel(R) HD Graphics


    Also, I don't know if these details are important, but I want to note that I did not actually use the link you provided, since when I clicked it, it said I had to contact my notebook manufacturer for a graphics driver update, so I used a similar link from the HP website. Also, when I was installing the HP version of the link you provided (which installed ATI Catalyst I think), at some point during the installation a window popped up saying "Access Denied" and when I closed it, ATI Catalyst opened and I proceeded to install the drivers.
     
  10. claptonman

    claptonman New Member

    Messages:
    5,481
    There's your problem. Your laptop is not using the 6770M video card, it's using the onboard graphics.

    Go into device manager and disable the onboard graphics and enable the 6770M graphics card, and then restart. That should be the problem.

    There might be an option to change it in the catalyst control center.
     
    Last edited: Jul 6, 2011
  11. diduknowthat

    diduknowthat formerly liuliuboy

    Messages:
    9,268
    Does your laptop use Optimus graphics switching? The drivers might not be working correctly and is stuck on integrated graphics.
     
  12. megamouth

    megamouth New Member

    Messages:
    5
    I got it working. It was in the CCC, under Power. I had to assign the GFX card to the game's .exe. Thanks for the help!
     
    Last edited: Jul 6, 2011
  13. Halodeath15

    Halodeath15 New Member

    Messages:
    1
    I am having the same problem you are. With the game computer you have. How do you fix it. I have tried switcher over to fix mod. I am running on the 6770m card and it still lags.
     

Share This Page