USB ports on side of Dell monitor not working

Discussion in 'Video Cards and Monitors' started by Martingale00, Feb 16, 2007.

  1. Martingale00

    Martingale00 New Member

    Messages:
    146
    Hi all, I have a Dell 1907FP with two USB ports on the left side of the monitor housing. Like said in the topic neither of the ports recognize hardware. I bought the monitor second hand and I'm running it through a non-Dell computer. The guy said he "thinks it might" have come with a CD for the monitor but he didn't remember for sure and if it did he never used it. Is there any way I can get these two USB ports working? Thanks in advance.
     
  2. Burgerbob

    Burgerbob New Member

    Messages:
    2,533
    You do have the USB cable from the monitor plugged into the computer, right? If you do, then try unplugging and replugging it, see if the computer even sees it as new hardware.
     
  3. Martingale00

    Martingale00 New Member

    Messages:
    146
    Yes, it has the USB cable plugged into the underside of the monitor that runs to the computer tower and the two open USB's are on the side. it's recognizing the monitor because it makes the "ding" noise when I unplug and plug it back in to the tower, but things plugged into the USB inputs on the monitor still wont work. Thanks for your reply. Think the monitor itself might be defective? I did get a smoking deal on it...almost too good to be true.
     
  4. Burgerbob

    Burgerbob New Member

    Messages:
    2,533
    Hmm, i would check in Hardware Manager for your USB hub, make sure it was working.
     
  5. hermeslyre

    hermeslyre VIP Member

    Messages:
    4,970

Share This Page