why does google.com show everything in Chinese?

Discussion in 'General Computer Chat' started by Darth Menace, Sep 13, 2008.

  1. Darth Menace

    Darth Menace New Member

    Hi my wife searched something on google not long ago and accidently changed my google search results to chinese (or some related language that I can't tell the difference) and when i go to the bottom of google there is a spot that says something likle set language but for some reason it won't let me change it. anyh help would be great
  2. chibicitiberiu

    chibicitiberiu New Member

    What browser do you use?
    Internet Explorer 6:
    Go to Tools - Internet Options and press all the delete buttons one after another, and say yes if it asks if you want to delete or not.

    Internet Explorer 7, 8:
    Select Tools - Delete Browsing History... and press Delete all at the bottom of the window. Confirm that you want to delete these files (yes) and press ok.

    Firefox 2/3
    Go to Tools - Clear Private Data (or press CTRL+SHIFT+DELETE), select all the checkboxes and press ok.

    That should work.
  3. StrangleHold

    StrangleHold Moderator Staff Member

    On Google click Preferences on the right-Then Search Language.
  4. Darth Menace

    Darth Menace New Member

    thanks for the help guys. for some reason it wasnt letting me choose google english, but clearing all my data and restarted helped :(

Share This Page