Is it just me?

novicegeek

Member
I have purchased my third Reeven Four Eyes Touch fan controller - and it was a little harder to find this last one. It seems I've had issues with all of them with displaying fan speeds and temperatures.

Is it just me? I mean, the installation seems pretty straightforward and idiot-proof, or is it the product? I am unaware of the product's/company's reputation, though I've tried to assertain that by on online search.

Maybe I've just got three lemons in a row. I don't know. I guess that is why I'm asking.

Incidentally, if I can't get this one to work, I think I'm just plugging all the fans into the motherboard and going from there.

Thanks.

P. S. Don't be dissin' my system. I like it old school - though it is getting harder to fill up the bays.
 

Attachments

  • IMG_2966(1).jpg
    IMG_2966(1).jpg
    21.9 KB · Views: 8

novicegeek

Member
Sorry, work has been killing me lately and I've run smack dab outta time. I'm back now. I've got a Gigabyte Aorus 390 Pro, but the fans are not hooked to the motherboard. The Reeven fan controller is not either. Just to the PSU for power.
 

novicegeek

Member
I'll do that, but I'm pretty sure I had everything right. I mean, it is really not that complicated. But, I will do that; however, it will take a little time. Life is crazy, and for now, the computer is running fine and there are no temp issues. Strange though, the rear fan (which is #4 on the Reeven panel) alternates between running and not running. It is at a dead stop now, with no fan speed showing. Other times, it runs. Odd.

In the end, it may be a hardware issue. As I've said before, I've had issues with these units. I have a replacement which I had purchased already lined up if I need to ditch this one.

Thank you.
 
Top