Computer will not recognize hard drive

Discussion in 'Desktop Computers' started by greggo2, May 7, 2009.

  1. greggo2

    greggo2 New Member

    Messages:
    12
    I recently picked up a gateway e4100 P4 2.8 ghz, 512 mb for 5 bucks!!! system came without a hard drive. I have tried three different hard drives in here and cannot get the system to recognize any of them. I can see them in the bios, but when I put in my win xp cd and get to the install screen, it tells me that it can not find a hard drive on my system. Any Ideas?
     
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,257
    Is your hard drive SATA? Go into your bios and make sure that the SATA controller is in IDE mode and not raid or ahci mode.
     
  3. greggo2

    greggo2 New Member

    Messages:
    12
    No, Hard drive is IDE
     
  4. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,257
    Still check your bios to make sure you don't have raid enabled. What motherboard do you have?
     
  5. greggo2

    greggo2 New Member

    Messages:
    12
    I believe it is a Gateway E4100 Motherboard, 4000888 by intel
     
  6. johnb35

    johnb35 Administrator Staff Member

    Messages:
    33,257
    Without giving me the model number of the computer, I can't really find out the exact motherboard specs. I've searched the intel motherboard number but its just a generic board and its not attached to any certain gateway computer.
     
  7. fmw

    fmw New Member

    Messages:
    474
    The BIOS will have a routine for restoring things to default settings. Do that.
     
  8. 2048Megabytes

    2048Megabytes Active Member

    Messages:
    4,369
    And if you can't find the option to restore your BIOS to default settings you can always pull out the CMOS battery and wait 45 minutes. That should put the default BIOS settings back. (Be sure to also put the battery back to its original place when your ready to start the computer as well).
     
    Last edited: May 7, 2009
  9. greggo2

    greggo2 New Member

    Messages:
    12
    ok, I took out the battery and reset. Now I am getting the message "Primary Master Drive ATAPI incompatible Press F4 to enter setup." I did that, and under Drive configuration, SATA0, and SATA1 are Disabled, IDE are set to Primary and Secondary. Tried again and get the same message.
     
  10. fmw

    fmw New Member

    Messages:
    474
    You have an IDE drive. Make sure it is jumpered for master rather than slave.
     
  11. greggo2

    greggo2 New Member

    Messages:
    12
    I picked up a SATA drive from a friend, installed, and got to the windows password entry screen. I don't know the password, and want to wipe the drive anyway, so I rebooted with a startup disk, to the c prompt. Now it won't let me do anything with the drive. Can't format, or even get a directory. And now when i boot again without the startup disk, it goes back to primary master drive ATAPI incompatable. I'm really stumped now.(as opposed to slightly stumped before.) Thanks to all for the help.
     
  12. Macky

    Macky New Member

    Messages:
    20
    try slaving the drive first to other computer and format it. then set the jumper to primary and attach it to your board. you can see the instruction labeled at your drive depending on what brand is your hard disk in setting the drive's status. set the Driver configuration to IDE set to primary if your using this cable. then proceed to installing XP.
     
  13. greggo2

    greggo2 New Member

    Messages:
    12
    Up and running, Thanks for all the help. Not quite sure exactly what made it work, but I think it was just a BIOS issue.

    Thanks again.
     

Share This Page