CISCO 877w Router config for Orange Broadband

russ75

New Member
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R10
!
boot-start-marker
boot-end-marker
!
logging buffered 16384
!
aaa new-model
!
!
aaa authentication login default local
!
!
aaa session-id common
!
clock timezone GMT 0
!
dot11 association mac-list 700
!
dot11 ssid ####your SSID####
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii ####your wireless passcode####
!
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool LAN-Pool
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 193.36.79.101 193.36.79.100 195.92.195.95 195.92.195.94
lease 0 12
!
ip dhcp pool MY-PC
host 192.168.1.100 255.255.255.0
client-identifier ####01 followed by your pc's mac address i.e. 0100.1574.6fa3.7c####
!
!
no ip domain lookup
ip name-server 193.36.79.101
ip name-server 193.36.79.100
ip name-server 195.92.195.95
ip name-server 195.92.195.94
ntp server 195.157.47.129
!
multilink bundle-name authenticated
!
!
!
username russ75 privilege 15 secret ########
!
!
!
!
!
!
bridge irb
!
!
interface ATM0
description ADSL PPPoA WAN PORT
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
no ip route-cache cef
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode adsl2+
!
interface ATM0.1 point-to-point
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
description CONNECTED TO HOST 192.168.1.100
!
interface FastEthernet1
description CONNECTED TO S1
speed 100
duplex full
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
description WIRELESS INTERFACE
no ip address
!
encryption mode ciphers tkip
!
ssid ####your SSID####
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0
channel 2462
station-role root
rts threshold 2312
world-mode dot11d country GB indoor
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
description MANAGEMENT INTERFACE
no ip address
ip virtual-reassembly
ip tcp adjust-mss 1452
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dialer0
description VIRTUAL DIALER TO-Orange-BROADBAND HOME MAX
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname ######your username######
ppp chap password ######your password######
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
!
interface BVI1
description BRIDGE-GROUP VIRTUAL INTERFACE
ip address 192.168.1.1 255.255.255.0
ip access-group 101 in
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
ip http authentication local
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.100 8055 interface Dialer0 8055
ip nat inside source static udp 192.168.1.100 8065 interface Dialer0 8065
ip nat inside source static tcp 192.168.1.100 40197 interface Dialer0 40197
!
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 deny tcp host 192.168.1.100 host 195.81.248.178 eq www
access-list 101 permit ip any any
access-list 700 permit ####mac address of wireless client#### 0000.0000.0000
access-list 700 permit ####mac address of wireless client#### 0000.0000.0000
access-list 700 permit ####mac address of wireless client#### 0000.0000.0000
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner motd ^C
--------------------------------------------------
Unauthorised Access Prohibited
--------------------------------------------------
^C
alias exec c conf t
alias exec i sh ip int brief
alias exec r sh ip route
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
no modem enable
line aux 0
line vty 0 4
exec-timeout 45 0
privilege level 15
logging synchronous
transport input telnet ssh
!
scheduler max-task-time 5000
end
 
Last edited:

russ75

New Member
:) no I didn't have a question. Sorry I should have explained. It took me a while to get this config working when I changed my ISP to Orange and I couldn't find anything on the net so I figured someone might find it useful.
Thanks anyway
 
Top