task bar not responding after update



I'm having an issue with my Windows 10 machine running on a Mac computer. I was watching a youtube video when suddenly it lost internet connectivity. I tried resetting my network settings and then Windows said it would reboot in 5 minutes. So I decided to save everything and just reboot now, selecting "update and reboot". After updates were install and it rebooted successfully (seemingly), an error popped up saying "Exception ESocketError in module WSHelper.exe at 000F0F0B.WSACleanup". And I found I couldn't click on anything in the task bar at the bottom. When I move the mouse down there, it gives me the busy icon (spinny circle), and when I click on anything, it seems to do something like refresh/reset the task bar as if fixing itself. But nothing is fixed. I still get the busy icon and can't click on anything. Every time I do, it does the same refresh/reset thing.

I can still click on items on the desktop and they seem to open fine (files, folders, application, but jpgs seem to have a problem for some reason). I can ctrl-alt-del to get the task manager and start things (like command terminals). I can also ctrl-alt-del and sign out, bringing me to the sign in screen where I can hold shift down, click the power/restart button and bring up the troubleshooting screen (where I can startup repair, startup settings, uninstall updates, etc.). But I'm not sure which option to choose to fix the task bar problem.

Without the task bar, I'm very limited in the things I can do, and I have to figure out a whole bunch of work arounds just to do simple tasks (some of which I'm not even sure have work arounds). I need some help figuring out how to fix this. Can anyone offer any suggestions? Thanks.


Thanks but it seems that system restore fails. Even if I try to restore to the earliest one, it tells me upon rebooting "System restore did not complete successfully. Your computer's system files and settings were not changed".

I did manage to get some task bar items working by opening msconfig from the task manager and selecting to boot with "Diagnostic startup: Load basic devices and services only" and disabled all the startup apps in task manager. Internet and volume weren't available but I could click on items and they responded.

If the problem is a specific startup app or service, then it may take me a while to pin down exactly which one(s) it is. I will post back if I ever discover the culprit. In the meantime, do you know which services/apps would I have to select in order to have at least internet and volume?


Hi John,

I found a solution that doesn't require disabling any services/apps. I kill StartMenuExperienceHost.exe in Task Manager, and then opening Powershell as an admin, I do this:

Get-AppxPackage Microsoft.Windows.ShellExperienceHost | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

That fixed everything except for the search box. It still won't respond when I click on it.


Staff member
You will most likely have to do a fresh install of windows to completely fix this. However, I would try doing the "reset this pc" with the option of saving your programs/files first to see if that solves it.