Cannot make a connection to Filezilla Server

Discussion in 'Computer Networking and Servers' started by Old_Soldier_1958, Nov 28, 2018.

  1. Old_Soldier_1958

    Old_Soldier_1958 New Member

    Messages:
    7
    What I am trying to do is create an FTP server for a limited number of family members to access to download files from anywhere.

    First time using Filezilla Server. Installing on a desktop with 8 tb of drive space and plenty of ram and a 6 core CPU. I have spent a week reading everything I can find on the various issues that have popped up but there is on issue I cannot fix and hope someone here may be able to help. Other solutions have not worked. I am probably doing something incorrect. The router is a Nighthawk x4.

    I will go through exactly what I have done so far and maybe someone can identify my error(s).

    Installed Filezilla Server

    Setup settings according to the way I have read the instructions numerous times. These are the setting I input.

    1st time settings.

    * Listen in on Port 50000-50100
    Passive:
    * Checked use Custom Port Range. 50000-50100
    * Checked Use the following IP Address and Input public IP address
    * Checked don't use external IP for local connections

    * Port on which the admin should listen- Default 14147
    * Checked Enable FTP over TLS support
    * Explicit and Implicit allow FTP over TLS
    * Listening Port for FTP over TLS - Default (990)
    * Force Prot P is checked
    * Resume TLS is checked

    On the router I enabled FTP and Port Forwarded 20-21 (They are forwarded by default when FTP is enabled)
    I also port forwarded 50000-50100. DDNS is on. Desktop shows up in access controls and attached devices as allowed. Use Router as DHCP server is enabled and

    My first result was a connection to the local host. Waiting for authentication. Logged on.
    I was able to create a folder on the local machine and add it then attach a (test) user to the folder.

    Running a test on Ftptest.net on the local machine the session kept timing out. I disabled all firewalls and it still timed out. I then (with disabled firewalls) and SIP ALG disabled ran another FTP Test and got the same result. Timed out.

    Although I can see the machine the server is on through my router from an outside computer, I am unable to access the folder or the server either from FTP (Local) or FTP (Internet), both are enabled in the router.

    I then changed the custom port range and listen in port range from 50000-50100 to 20-21.

    Then doing an FTP Test the error was "Connection Refused".

    Hopefully someone can tell me what I am doing wrong.
     
  2. Cromewell

    Cromewell Administrator Staff Member

    Messages:
    15,256
    ftp test will be connecting in on 21. So it wouldn't be able to connect to anything internally on 50000. You could forward from 21 to 50000 in your router (probably) or use the standard ports, or test with an ftp client and the custom port.

    Are you running windows firewall or any other firewall? If so you need to allow connections in on your listening ports there as well.
     

Share This Page