Can't open port in Windows 10?

Discussion in 'Computer Networking and Servers' started by finsfree, Jan 18, 2017.

  1. finsfree

    finsfree Member

    Messages:
    239
    Hi,

    I'm trying to access a computer outside of my network using RDP port 3388.

    I already have my network firewall (Zywall USG 20) setup to use RDP port 3389 for another computer, so I can't use the same port for 2 different PC's. And "NO" I don't want to use 3rd party software like teamviewer or VNC!

    I have created a "rule" in the Windows 10 firewall to open port 3388. In addition, I had to change some settings in the Windows registry to RDP 3388.

    However, I still can not connect.

    To test my issue, I used "netstat -a" to see all open ports and port 3388 didn't show up. Also, used www.canyouseeme.org to see if 3388 was open and it wasn't.

    Why am I not able to open ports on a Windows 10 Pro PC?

    Oh BTW, RDP is getting though the network firewall (Zywall USG 20) just fine according to the log files "port 3388 accepted".

    Thanks,
     
    Last edited: Jan 18, 2017
  2. beers

    beers Moderator Staff Member

    Messages:
    7,457
    Did you permit the traffic on the Zywalll ACL as well?

    You would use 3388 on the WAN IP but it should forward to 3389 on the LAN IP.

    Also, I wouldn't really expose those directly to the internet (in addition to being on default ports). A VPN would be a better solution.
     
  3. finsfree

    finsfree Member

    Messages:
    239
    At this point, I'm not trying to hide anything. I just want to RDP into 2 different PC's.

    If I can found out why I can't open up ports on my Windows 10, I think I can solve this issue.
     
  4. beers

    beers Moderator Staff Member

    Messages:
    7,457
    Why are you opening 3388 on the Windows PC instead of 3389?
     
  5. finsfree

    finsfree Member

    Messages:
    239
    Because I already have port 3389 pointed to another PC. I want to be able to RDP into 2 different computers but I can't use the same port (3389) so that is why I chose 3388 (different).
     
  6. beers

    beers Moderator Staff Member

    Messages:
    7,457
    The port would be 3389 on the Windows PC. On the external IP you would forward 3388 to 3389 internally.
     
  7. finsfree

    finsfree Member

    Messages:
    239
  8. finsfree

    finsfree Member

    Messages:
    239
    I'm guessing the best way would be to forward the port the PC like you are saying. I always know there was a better way than to mess with the registry.:rolleyes:
     
  9. voyagerfan99

    voyagerfan99 Master of Turning Things Off and Back On Again Staff Member

    Messages:
    22,832
    Once you change the port in the registry you need to restart the computer. So if you didn't do that, it will still be on 3389.

    You also still need to forward the port on the router if you have not done that already.
     
  10. finsfree

    finsfree Member

    Messages:
    239
    Thanks but I think I'm going to do what beers said and do port to port forwarding in the network firewall.

    Makes more since.
     
  11. finsfree

    finsfree Member

    Messages:
    239
    And yes by the way, 3388 did work after a restart. It was pretty cool to know that but it's better to just let the firewall do all the port configuration.

    Thanks again,
     
    beers likes this.

Share This Page