Can't see windows 10 shares, but can see Win7 shares from Win10 side


New Member
Like the title, I'm able to see Windows 10 shares if I'm on the win10 machine, but when I switch back to my Win7 computer I can't see win10 shares. But I'm able to get to my windows 7 shares from windows 10, just not the other way around. I've exhausted every soluton I've found on google searches.
I had this working before, I replaced my router and my network changed from network 1 to Network 3, or maybe it stopped working sooner but I didn't notice. But It was working two ways before all this. Now the only way to get a file transferred is, I have to place the file into a shared folder on the Win7 machine and then go to the win10 machine and drag/take it from there.

What's odd is, I can see the Windows 10 machine from the full map (in network sharing center) while I'm in Windows 10, but I can't click it.

  • Discovery services is on for both machines for privet network, Tried tuning on public shares but made no difference.
  • Both computers are part of workgroup, but have different computer names, that never mattered in the past.
  • SMB service in applications is checked on the Win10 computer, but that's not an available option under win7
  • File and Print sharing under adapter is turned on on both machines
  • IP4 and IP6 are installed.
  • NetBIOS is turned off, never needed that before.
  • Network type is privet on both machines.
All these services are turned on and set to automatic
  • IPv6
  • SSDP Discovery
  • Publication
  • Function Discovery Provider
  • DNS Client
  • Peer Networking Group
  • Host
  • Function Discovery Result
  • UPnP Device Host
  • Home Group Provider
  • Home Group Listener
Last edited:
but have different login names
Different credentials has always mattered, if you don't have centralized AAA then you'd be leveraging the creds of the remote host when connecting.

Might be related to the SMB versioning matrix, but IIRC 10 supports SMBv2 out of the box as does 7.

Going to have to do some sleuthing to see what you may have changed to impact that functionality.
SMB service in applications
That's probably SMBv1 support, which has a lot of flaws and is disabled by default which changed pretty recently:

hello Beers
One typo, the user and passwords are the same on both computers, the computer names are different. What's changed is the network connection number. When I setup the new router, a new network connection and number was established.
As far as SMBv1, it's installed on Windows 10 though the add remove features, but I don't see it under windows 7 at all.
I'm not sure what centralized AAA or IIRC 10 is? But If I were to create a new credential with the add credential option, is that something I have to logout and back on to use? I've never used the credential feature in windows, but It's come up with this topic. I thought when i created my user account, it just made one that was built in.
Last edited:

Just so you are aware, you are editing your post multiple times and the system is wanting us to reapprove your post, I've had to do it 3 times now. So try to get all the info posted the first time. Thanks. Your post won't show up publicly until its approved.
Did you choose private on both PCs for Windows Firewall when upgrading the router?

If one side is classified as the 'public' firewall zone then it can reach out but not accept connections, such as Win10 being able to access other shares but others not being able to access Win10 shares.
Sorry Johnb35. I didn't realize it worked that way. I was trying to reword my post to better explain it.
I'll take more time revising on the first post. Thanks

@ beers
Both firewalls are set to privet on both machines. But I even tried disabling both on both machines and it made no difference.
Tell me about this new router setup. Did you re-use one at any point such as for a switch in a different area? What did you upgrade from/to ?
Before I answer that beers, I just noticed something strange: I'm able to map a drive letter to my windows 10 machine. It doesn't show up in the network places like on windows 10 though. Anyway, the Windows 10 computer name is: GAMES-PC and the folder I wanted to access is 'common' So while in windows 7, I mapped a network drive just by typing the path: \\GAME-PC\common and it shows up as a mapped drive link in my left navigation pan, but not in network places.

Anyway, I was using an Netgear-SRX-N3205 prosafe. I loved the router, but it was capped at 60Mbps and still using the old SSL certs, so after all the browsers forced their new certificates, the add exception rule disappeared as an option at the router login screen and the only way to get into my router setting was to either use a really old portable version of FireFox or a string you could type in about:config:

To turn off SSL3 in firefox: enter about:config into the address bar & search for the preference named security.tls.version.enable-deprecated

double-click it and change its value to 1.
NOTE: I had no 1 or 0, in my version of Firefox. There was only True or False. false being the default. I set mine to TRUE and I'm now getting the advanced button again to add the exception.

Either way, I know I was way do for an upgrade. I went with an ASUS AX1800 WiFi 6 (RT-AX55). I have reserved IP on all devices, wifi and wired. Everything is working great.
What is strange though is, this csm biscuit devices that shows up, but I read that it's not actually on my network, but more broadcasting like an SSID.