Class Not registered

Discussion in 'Desktop Computers' started by lostsoul62, Aug 5, 2018.

  1. lostsoul62

    lostsoul62 Member

    Messages:
    601
    I have a 955 AMD computer, Windows 7, with a SSD Drive. When I try to load Quake 4 I get the error message "Class Not registered" Quake 4 has played in this computer before several years ago. I tried sfc/scannow in the command line as the admin. and got " Did not find any "Integrity Violations". Anyone have an idea of what I should do next?

    I have a i5 4690, Windows 7, with a SSD Drive. When I try to load Quake 4 I get the error message " Library not Registered" Quake 4 has played in this computer before several years ago. I tried sfc /VERIFYONLY in the command line as the admin. and got " Did not find any "Integrity Violations". Anyone have an idea of what I should do next?

    In both of these computer when Quake 4 worked I did not have an SSD drive but I don't think that could cause this?
     
    Last edited: Aug 5, 2018
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    40,909
    Run it compatibility mode for XP and see what happens.
     
  3. lostsoul62

    lostsoul62 Member

    Messages:
    601
    I click on the properties on setup but there was no XP mode.
     

    Attached Files:

  4. johnb35

    johnb35 Administrator Staff Member

    Messages:
    40,909
    Check the box where it says run in compatibility mode. You'll see windows XP already in the box but you still have to enable it.
     
  5. lostsoul62

    lostsoul62 Member

    Messages:
    601
    Thank you, I understand now but other problems come up so I will make another post because it's a different problem. Thank you again.
     

Share This Page