Corsair Power Supply Starts/Stops for 1 Second

Discussion in 'Computer Cases, Power Supplies and Cooling' started by Matt M, Apr 10, 2012.

  1. Matt M

    Matt M New Member


    I have had the same setup working perfectly for over a year. Three weeks ago I turned on my computer, all was fine, came back hours later to find the computer off but the desktop case/fans and power supply were lit up and spinning slower than normal. I toggled the power switch on the PS (Corsair 600W) and then proceeded to start the computer again but it would not start. No response at all except the green light on the motherboard would remain lit. I tried plugging it into another desktop with the same result so I concluded the PS died on me.

    I shipped it to Corsair. In the meantime I purchased a backup PS (Dynex 520W) on eBay and installed it and everything works fine.

    Fast forward to present day when I received the new Corsair replacement. I take out the Dynex, replace it with the Corsair, and again the computer will not start. This time the PS will begin spinning (sometimes the light will flash on) for only ~1 second. It will only do this once however, I have to physically unplug/replug the power cord for this result to reappear. No the Dynex is back in.

    Any ideas? Could I really have received a bad replacement power supply, or am I missing something?

    Thank you!

  2. Machin3

    Machin3 New Member

    That's pretty rare that you would have a dead power supply and then receive a dead power supply replacement. I don't think that would ever happen with corsair as they make some of the best power supplies on the market.

    Do you have everything plugged in correctly and all the way in? 8-pin, atx connectors, ect?

    Also, since you say it starts and then right away stops, in the back of my head I keep thinking that it seems as though something is causing your system to short out.
  3. johnb35

    johnb35 Administrator Staff Member

    Yeah, considering Dynex is Best Buy's brand and the Corsair is way better then the Dynex. But why would the Dynex work and both Corsairs not? Did you try building the system outside of the case to verify you weren't shorting out the motherboard?
  4. MMM

    MMM New Member

    Cheaper PSU's most likely do not have power Good signal circuit installed in the PSU where the Corsair PSU will have one.
    I would imagine your motherboard could be faulty, or as suggested check all your component connections including cards ram etc etc as this can be your problem.
  5. cabinfever1977

    cabinfever1977 New Member

    Since the Dynex works and the Corsair does not,maybe they sent the bad one right back to you by mistake,try the corsiar one in another computer,if it still doesnt work then its another bad one.

Share This Page