External Hard Drive will not initialize

Discussion in 'Computer Memory and Hard Drives' started by sup2jzgte, Feb 13, 2009.

  1. sup2jzgte

    sup2jzgte New Member

    I have a Western Digital WD 500 External hard drive that I can not get to show up in MY COMPUTER. THe issue is according to Western Digital these hard drives will not work for Vista 64..................that is hard to believe honestly, but who knows. Anyone have any ideas how I can get this to work?

    It shows up in Device Manager and Disk Manager, but not in MY COMPUTER. When I try to format it from Disk Manager I get an error saying that the drive has not been initialized and it is unallocated. I have tried all 8 of my USB ports, pulled the hard drive out and hooked up with a few different adapters and even tried going directly to the mobo and nothing works.

    The model number in the hard drive is WD5000YS:confused:
  2. Cromewell

    Cromewell Administrator Staff Member

    This may be a silly question but what if you pick Initialize before you try to format?
  3. sync

    sync New Member

    If WD say those particular hard drives don't work with vista, why do you find that hard to believe?


    Just found this link on microsofts website, apparently it's supposed to be compatible. Allthough the model number is showing up as an internal hard drive and not an external one. But maybe that picture is just for display purposes?
    Last edited: Feb 21, 2009
  4. sup2jzgte

    sup2jzgte New Member

    FINALLY................I had to use the software from my World Book to get Vista to see the older drive. Thanks for the help everyone

Share This Page