How can I set Gmail as my default email program in Chrome?

JohnJSal

Active Member
Hi all. When I try to share something via email from a website, I get a dialog box that says "There is no email program associated to perform the requested action." I have searched for how to set Gmail as the default, and I've found some instructions for going into Chrome settings to do it, but maybe the instructions are outdated because I can't find the sections they are referring to, like "Content Settings" or "Handlers."

Can someone tell me how to do this on the newest versions of Chrome?

Thanks!
John
 

C4C

Well-Known Member
I found this Google Support article that recommends:

  1. Open Chrome Browser and click More
    and then
    Settings.
  2. At the bottom of the page, click Advanced.
  3. In the Privacy and security section, click the Right arrow
    next to Site Settings.
  4. Towards the bottom, click Expand
    next to Additional permissions.
  5. Click the Right arrow
    next to Handlers.
  6. Turn on Allow sites to ask to become default handlers for protocols (recommended).
  7. Open Gmail in your Chrome Browser.
  8. In your browser’s address bar, click Service handler
    Service handler
    .
  9. Click Allow
    and then
    Done.

Source: https://support.google.com/a/users/answer/9308783?hl=en

Edit: I've been suffering with this and tried this out... found out that gmail.com was blocked! Works now, hope you have similar results.
 

JohnJSal

Active Member
Thank you so much! It turns out that Gmail was blocked for me too! I guess at some point I chose to deny it access, not understanding what it was trying to do, perhaps.

The only thing that didn't quite work for me was that I didn't see a "Service Handler" icon in the address bar, but going to Gmail for the first time automatically showed a pop-up that asked me if I wanted to allow it access, so I just chose "Allow" that way.

Thanks again!
 
  • Like
Reactions: C4C
Top