HP Network printer will not connect to HP network Laptop


I have a HP Envy Notebook (LAPTOP-PI6DODCQ) connected to a wireless network along with an HP Office Jet 4635 printer also connected to wireless network.

Up until last year I was able to use the printer and then there was some sort of update and now I can use it at all because it says ‘No driver’. When I try to update the driver, it says driver no longer supported and I can’t get one. I can connect the printer with a printer USB cable and it works , just not wireless.

Anybody have any ideas on how to fix this?

Note: My daughter has no problem printing from her phone and I've been sending stuff to her via email and she prints it from her phone.
Oh I almost forgot, I have Windows 10 Home installed
Last edited:


Staff member


There was an update that came through that caused printing problems from wireless. However, I do believe they pushed an update to fix this issue. Make sure Windows is fully updated. Next step would be to uninstall the printer software in the programs list, remove the printer from the printers section and then download and reinstall that printer from here.

That should solve it.
WOW, thank you so much! That worked except that I had over 20 files in the print spoiler from over the past year since the printer stopped working. I tried clearing out the files in the spoiler, but it keeps saying I don't have permission.

I did finally delete some files in the 32 bit system files that looked like printing stuff, but I think the printer itself has some files stored in it as well because It seems to be printing the continuation of a 12 page file I canceled when I tried to print earlier from my phone that was set wrong.

I ended up giving the file to my daughter who emailed the signed copy directly to the sender. I'll have to do some research on how to clear out everything in the printer when I have more time. But Thanks again for your help.


New Member
The Restarting the printer spool service would be the best bet there in that link.

As to the "I don't have permission" part, you should make sure that the security group Everyone has the ability to manage the printer and documents in the Security Tab for the Printer properties.