I need help with XAMPP and port :8080

Discussion in 'Computer Networking and Servers' started by LainJeremy, Jan 16, 2020.

  1. LainJeremy

    LainJeremy New Member

    Messages:
    29
    Hello,

    So I have setup a server using XAMPP and I have forwarded my domain to the WAN IP address of the server.

    I have typed example - mywebsite.com and it takes me to the IIS (Internet Information Services page on the webserver) I am guessing on port 80.

    I had to edit the conf file to get the XAMPP server to start because there where conflicing ports it and XAMPP couldn't run on port 80 because I guess windows by default
    uses this port for http:. I had to use port :8080 to get XAMPP to start.

    Once started and I have mywebsite.com forwarded to my wan and port forwarded on the router to 8080, the only way I can see my website from a browser is by typing this.

    mywebsite.com:8080

    What can I do to get this working correctly, so that when people type mywebsite.com it takes me to the website?
     
  2. Cromewell

    Cromewell Administrator Staff Member

    Messages:
    15,404
    Forward from port 80 on your router for 8080 internally. Or turn off IIS, which is what is taking port 80 and start your apache service on port 80.
     
    voyagerfan99 likes this.

Share This Page