WIndows 10 It doesn't go to sleep anymore?

ssal

Active Member
I have the power setting in my desktop (Ryzen 7 2700x, GTX 1060, 32 GB DRAM, M.2 SSD, HHD) set to sleep after an hour. It used to do it.
But now, the screen with be off, but the CPU and the fans are still running overnight.

Any idea why it doesn't sleep anymore?

And, how much energy it's using if there is not activity, other than the CPU and fan active?
 

johnb35

Administrator
Staff member
Sounds like you just have the monitor to go to sleep not the computer itself. Double check the settings.
 

johnb35

Administrator
Staff member
Any new hardware or software installed recently? Anything active will stop it from it going to sleep. Any updates installed since it was working properly?
 

ssal

Active Member
Any new hardware or software installed recently? Anything active will stop it from it going to sleep. Any updates installed since it was working properly?
No new hardware. Only updates are regular Windows 10 update.
 

johnb35

Administrator
Staff member
Try changing sleep to never then save, then change it back and see what happens.
 

johnb35

Administrator
Staff member
Not sure what to tell you then. It's either software or hardware related. Without knowing what has changed on your system recently, its hard to tell you what to do.
 

ssal

Active Member
The not going to sleep problem persists. Even when I manual set the machine to sleep at night and it will be running with the blacked up screen in the morning.

I did a bit of pondering and figured that there must be something in the machine that wakes it up in the middle of the night. Then it dawned on me that when Windows was updating, it scheduled itself to update/install at my off hours. I searched for "schedule" and found that there is a Scheduled Tasks function in Windows 10.

There are 4 or 5 thing scheduled (not by me) like Google update, MS Edge update and Adobe GS update and Google update, etc.

Can I delete all schedule tasks, or even better, disable all scheduled tasks from running?
 
Last edited:

johnb35

Administrator
Staff member
You can always update manually. Either disable those or delete them and see if it goes to sleep. But to be honest, you should totally shut it down at night as the system should be rebooted daily anyway to clear out ram and other things.
 
Top