Medal of Honour: Airborne Wont Install!

Discussion in 'Computer Games and Consoles' started by GOA-E, Jan 7, 2009.

  1. GOA-E

    GOA-E New Member


    Once Again I need help!
    I bought my Legit copy of Medal of Honor Airborne from the shops today. My problem persists with trying to install the game, I Choose my language, Click Install, Enter the CD key, It does the a small splash screen saying * Preparing to install * , Then a CMD flashes for 0.1 of a second and then nothing. I've tried it several times and still no luck.

    Any Suggestions?

    p.s On vista 32 bit.
  2. mrjack

    mrjack VIP Member

    Do you have administrator rights or tried right clicking and choosing to run it as administrator? That often solves issues with software not running in Vista.
  3. GOA-E

    GOA-E New Member

  4. deedub

    deedub New Member

    Had the same problem when I tried to install Medal of Honor Airborne yesterday on my Vista x64 system. I would get the installation menu on Autoplay, but after I hit Install, the program just hung up forever and would not continue when it came to the PhysX driver installation window. I tried installing as Admin, using the Vista computability function, etc., but nothing worked.

    In my case the installation problem turned out to be the PhysX drivers that were already installed on my system. I uninstalled them, and after I did that, MOH-A installed perfectly, then I went back and reinstalled the PhysX drivers.

    The game works perfectly on my system, even though EA says that Vista x64 isn't supported.

    Hope this helps.

  5. septiktank

    septiktank New Member

    medal of honor airborne physx problem

    l`v have the same problem instilling medal of honor airborne.when l updated nvidia drivers with the lastest. 181.22 its the physx.there to high for airbourne.had to uninstall the version 9 physx drives. then install the ones that came with airbourne.physx 7 version then it worked.l think ea need to patch it of nvidia need to add airbourne to there next nvidia update.
    the sometimes l get emulator error.youd think thay would fix this problem for it a great game that be scewed up again.
  6. Ender07

    Ender07 New Member

    Go to Control Panel>Add and Remove Programs>remove AGEIA PhysX

    I did that and now it works...try it and then goto autorun in the explore folder of the disc...hope this helps!
  7. tecknopunk

    tecknopunk New Member

    I had the same problem too and i reverted to installing the original driver that came with my vid card then installing the game and it worked. However once i got it installed, i still wasnt able to install its updates. it looks like they install but when i tried installing the 1.3 update it said i needed to update to the 1.2 update which said it installed properly. so i dont know what the deal is with the updates.
  8. misternicky

    misternicky New Member

    MoH Airborne install fix

    I created a fix that allows you to install MoHA without changing your PhysX (Nvidia) drivers, and without installing the old PhysX drivers on the MoHA DVD

    It also allows you to install MoHA on PCs that don't use/have Windows Firewall (aka ICS)

    Fix is at


    KILRBUD New Member


    i cant believe i am reading this.. i am having all of these issues and cant believe that the creators of this game have not fixed it as of yet. please tell me,does the hot fix i see here really work? and will removing the PhysX (Nvidia) drivers make the game install? and if i remove them how do i get them back, and also, how do i remove them, is it like removing any software, control panel, remove programs..and so on, or do i need something to remove the drivers with?? sorry for all the questions, but i have more games then some stores..and i never had these issues installing any type of game before, thanks in advance for any help I truly appreciate it.

    P.S. I so wanted to give this game a try, and am quite pizzed that all the games in the 10th anniversary edition i got installed perfectly and the one i want to play the most, "airborne" will not install...

    after all the time the game has been out, you would have thought ea, would have fixed it, but i removed and reinstalled the phyx stuff and the game finally installed,
    Last edited: Dec 7, 2009
  10. BaconMan

    BaconMan New Member

    I have a little bit of the same problem. I installed Medal Of Honor Airborne (from the 10th anniversary pack) and a text box says "game card not supported! I need help!:confused::(:confused:
    PC: Windows XP
    Last edited: May 8, 2011

Share This Page