MP3 player not recognized

Discussion in 'Computer Accessories' started by DeltaDart1, Nov 8, 2017.

  1. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    I have 3 mp3 players that I use for a ear condition. The oldest is 5 years old. Until yesterday all worked with my computer & WMP. Now all 3 are not recognized by my computer. I have Windows 7. Bought a new one today and it will not work either. Have tried all the fixes that I have searched for. Anyone know why all of a sudden this would happen? Pretty strange. Thanks!
     
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,818
    Go into disk management and see what it says. You can also try uninstalling the usb's in device manager and then reboot and see if that fixes it.
     
  3. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    Did that a couple of times and it says it's not successfully installed. Don't understand why the new one won't work. Strange problem just like my Google Maps situation. Fixed that by deleting Google Earth.
     
  4. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,818
    Run an elevated command prompt, type "sfc /scannow" without the quotation marks and press enter. This will scan for any missing or corrupt system files. Or you may just want to reinstall windows. Something is corrupt. Do these work on a different pc?
     
  5. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    Tried it on a laptop with Windows 10 and get the same result. Also found an old MP3 player and it works perfect.
     
  6. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,818
    Not using the same usb cable are you? I'm not sure what to tell you.
     
  7. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    Tried a different cable. Your best guess,is it the players(all players are the same brand) or the computer?
     
  8. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,818
    What brand?
     
  9. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    Coby MP-620 Have used them 7 days a week for years. They still work just can't connect to the computer. Was always very easy to use with WMP.
     
  10. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,818
    Well if you can try them on a couple more pc's to see what the results are then you can just about verify what the issue is.
     
  11. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    Agree. So far have only tried them on our other laptop. Same result. I just now plugged in my Fiio mini amp to charge and I get the same message. Got to be the computer I would say.
     
    Last edited: Nov 9, 2017
  12. DeltaDart1

    DeltaDart1 Member

    Messages:
    259
    johnb35, Go figure. All my MP3 players just started working about an hour ago. Strange.
     
    johnb35 likes this.

Share This Page