No display

Discussion in 'Video Cards and Monitors' started by CheckeredStuff, Jan 4, 2018.

  1. CheckeredStuff

    CheckeredStuff Member

    Messages:
    47
    I have a lenovo e72 desktop pc but ive switched out the case, psu and gpu
    so its:

    i5 3470s
    4gb ddr3 ram
    the stock motherboard from the e72 idk
    sapphire r9 280
    corsair cx600m psu.

    It was all working fine (2 years i think) until i had to test another r9 280(asus version) in my pc to see if it works (the fans were spinning but no display and it beeped but im not sure how many times).
    So i reinstalled my own 280 and i also get no display now but mine doesn't beep.

    I can use the onboard gpu if i remove the 280 but whenever its plugged neither of them gives me a display.

    First thing i did was try all the solutions i could find on google so i tried disabling the intel hd from device manager and resetting the bios from both the menu and with the clearcmos plug things. I tried uninstalling all drivers.

    Also wanted to do a bios update but there's none for windows 10 on the lenovo support page. (maybe i should reinstall win7 ?)

    Its also possible i might have screwed up my gpu or motherboard when switching the gpus.

    So i'm just wondering if anyone has any more ideas for what i could try.

    Thanks :)

    Edit: just realized the title is incredibly vague, sorry about that
     
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,984
    Did you connect the pci express power connectors to the video card? If resetting cmos doesn't bring back video using the onboard then its possible you did something to the motherboard. First, try removing and reinserting the memory sticks.
     
  3. CheckeredStuff

    CheckeredStuff Member

    Messages:
    47
    Hey thanks for the quick reply!
    I did connect the pci-e connectors to the gpu, the fans worked etc.

    The onboard gpu works (using it right now) but it doesn't if the 280 is also connected so i think it actually detects the 280 and tries to use that but doesn't give a display.

    I did also try removing and reinserting ram but im guessing everything is working fine since i'm using the pc right now with onboard gpu.

    i'm not sure if i did the cmos resetting procedure correctly tho. I had 2 of the plugs with "clear_cmos" and "clear_cmos1" i moved the jumper 1 step to the right on both of them (both featured 3 plugs? with the jumper connecting 2) then started the pc for like 10 seconds and powered it off and moved the jumpers back.

    I'm thinking i might have either broke the connection on the gpu or motherboard(nothing visible tho) but at the same time i think it would beep then ?
     
  4. johnb35

    johnb35 Administrator Staff Member

    Messages:
    39,984
    When inserting a dedicated video card, it overrides the onboard video so thats why you don't get any display. You probably have damaged the video slot somehow. However, you can try going into the bios settings to see if there is a video output setting to display output from onboard or pcie express first. Some motherboards do and some don't.
     
  5. CheckeredStuff

    CheckeredStuff Member

    Messages:
    47
    I can change the setting from "auto" to "peg" but when i "save & exit" it restarts my pc and since i can't have the 280 plugged while accessing bios, it resets to "auto".
    And the default "auto" setting prioritizes pcie over integrated, so i guess it probably wouldn't matter either way?

    Anyway, it seems to be a hardware problem so i'll just try to find another gpu to test in my system to see if and what i damaged.

    I really appreciate the replies, thank you :)
     
  6. jd132

    jd132 Member

    Messages:
    416
    Have you tried using the Asus 280 you tested again after your Sapphire card wouldn't show video? The only thing I can say to do next would be to test with another GPU. If it doesn't work, try all components with a different mobo. Good luck!
     

Share This Page