Onboard Sound and dedicated sound card not working

Discussion in 'Sound Cards and Speakers' started by waffles, Jun 18, 2018.

  1. waffles

    waffles Member

    Messages:
    116
    Hey everyone!
    So my Soundblaster Z card has been really buggy, the center channel doesn't work half the time, and channels switch and between each other and turn off randomly. I tried everything I could find on the internet but nothing worked so I decided to use my onboard audio. Unfortunately that doesn't work either -_-. Theres only two situations Ive found where it works. When I configure the speakers, and click test it I hear the test sounds. The second way i can hear sound is when I play starcraft 2. I tried a couple other games but starcraft 2 is the only game that sound works with. I've tried everything I could find on the internet for both my dedicated and onboard sound. Does anyone know how to fix either?

    Things I've tried with Soundblaster z Card:
    Reinstalling soundblaster software, rolling back drivers, disabling onboard sound.

    Things I've tried with onboard sound: installed latest drivers multiple times, configured sound.

    For both, I made sure the correct device was the "default device" in the sound control panel.
    Im really at a loss of what to do. Any help would be much appreciated!
    Motherboard: GIGABYTE GA-990FXA-UD3
    Onboard Audio: Realtek HD audio
    Speakers: Logitech z506 5.1 surround sound speakers
     
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    41,325
    You got it in the right port? Tried different speakers. I mean if both onboard and dedicated sound has issues, it might be the speakers or cables.
     
  3. Agent Smith

    Agent Smith Well-Known Member

    Messages:
    3,324
    Are you using Windows 10? I heard about updates messing around with audio recently.
     
  4. waffles

    waffles Member

    Messages:
    116
    Yup correct ports. The same channel switching happens on my headphones which work fine with everything else. I don't think its a speaker or cable issue, just the way it switches channels and stuff on the dedicated sounds like a software problem and the on-board sound only working when using special applications also seems like a software issue.
    Yup I'm using Windows 10 :)
     

Share This Page