PC, Memtest86+ hangs: what to do?


New Member
My PC running Ubuntu 20.04 LTS started hanging in random moments, after I brought it with me on an international plane (it's in a tiny mini-ITX case, so I took it with me as hand luggage and handled with care).

When I boot Memtest86+ from GRUB, it starts but hangs at 1 second mark without showing any error. The red '+' symbol continues flashing perpetually, but the program stops running and doesn't respond to key presses anymore. In Safe Mode the result is unchanged. There are two DDR slots on the motherboard, populated with identical Kingston memory modules. I have tried removing them and installing back, one by one, in all possible combinations (one module, two modules...) to no effect.
I tried fiddling with BIOS, in particular resetting it to optimized defaults (just because I see no option to reset to regular defaults) and back, manually, to no effect.
Changing between the discrete and integrated GPU has no effect. So does disconnecting all the non-essential peripherals.

What is likely the matter? What should I do to fix my PC?

Here's my take: it's probably the motherboard that is broken somehow (socket?) and has to be replaced. Just because the CPU is pretty sturdy and hard to break when it's properly socketed and RAM defect is out of the question by testing. Am I right?


Here's the computer's specs, just in case:
Case: NCASE M1 v5.0
PSU: Corsair 600W 80 Plus Platinum
CPU: Intel Core i7-4770S
RAM: 2x8GB Kingston PC3-1333
SSD: Samsung 860 EVO 250GB
VGA: MSI GeForce GTX 1050 Ti GAMING X 4G
Extras: E-MU Tracker Pre USB2.0 soundcard, Logitech C920 webcam, D-Link USB2.0 active hub which I disconnect for testing.
Ubuntu 20.04 LTS with Unity installed.


Staff member
So where it says test 64%, that number never changes? If it does then its still running.


New Member
Do you have more than 1 stick of ram in there? If so, try testing 1 at a time.
Yes, there are 2 sticks and I tried changing their position as well as testing only one at a time, in any position; all to the same effect. I did all that testing with Memtest86+, though.

For now, I decided to risk it and upgrade the BIOS from version 0707 to 2305 (H81I-PLUS-ASUS-2305.zip). If it ain't broke, don't fix it, I decided originally, but now that it did broke... maybe the BIOS upgrade will fix ECC support or something, I thought.
The upgrade went smoothly, testing now.

The thing came to my mind: why is my RAM working if it's ECC? Should ECC RAM work at all? Don't remember why I bought ECC specifically; maybe the seller didn't advertise the fact? Definitely the price was good and it worked.
I have originally assembled this PC from the used parts (except for the cooler) and one thing I know is it did work well for well over a year, pretty intensively at times (played through 3xDiablo II Resurrected), casually browsing at others, and it didn't hang. Also, I did run Memtest86+ after installation.
Now it hangs.


Staff member
Which specific kit are you using? You can use unregistered/unbuffered ECC DIMMs in most consumer setups, but it's a toss up as to whether ECC is actually enabled or utilized depending on the platform and BIOS etc. Registered DIMMs won't function on a consumer platform.

You might be able to leverage something like memtester from a Linux bootcd if you're having memtest86+ hang, it might also depend on your RAM parameters in BIOS.