Pc won' start after RAM upgrade


New Member
I've encountered a proboem when Intried to install new ram for my pc.
AMD Ryzen 7 3700x Speed: 3600mHz
Motherboard : Asrock B450 Pro4
Ram : 2x Gskill Aegis DDR4 3000mHz 8Gb

I tried to install 2x 8Gb of the EXACT same ram but the pc just wouldnt boot when I started it. The new ram is not defect, it worked when I swapped out the old sticks with the new ones. It just wont start when I put in all 4 at the same time. In the BIOS the two modules are listed as DDR4-2133, so I would think that they are running at 2133 mHz. So my question would be if I need to change any settings in the BIOS or if it is another problem.


Staff member
Then there is an inconsistency between the 2 sets somewhere or you have a bad ram slot. Try with just 3 sticks and see what happens. Use the 2 original slots that were used and then insert 1 new stick in one of the other slots and try booting up, do the same with the other slot. If it boots up both times then remove old ram insert new ram in its spot and then run memtest on the new ram to see if there are any errors.