Programs crashing on external hard drive

Discussion in 'Computer Memory and Hard Drives' started by ZeIndieGamer, Aug 16, 2018.

  1. ZeIndieGamer

    ZeIndieGamer New Member

    Messages:
    3
    Recently every program running on my hard drive has crashed after a few minuets of running. But they work on my internal hard drive. But using my internal is not an option due to its small storage space. Does anyone know what the problem could be? (It's not the drive disconnecting because sometimes the program has a crash report that opens)
     
  2. johnb35

    johnb35 Administrator Staff Member

    Messages:
    41,664
    How did the programs get on the external? If you copied them then thats probably the issue, most programs can't be copied, they have to be installed on the drive that is physically being booted from.
     
  3. ZeIndieGamer

    ZeIndieGamer New Member

    Messages:
    3
    There were installed directly onto the external. (When i tested on the internal i copied them off the external so i know thats probably not the problem and i also know the test used the same files.) BTW this has never been a problem till recently.
     
    Last edited: Aug 16, 2018
  4. johnb35

    johnb35 Administrator Staff Member

    Messages:
    41,664
    What does the crash report say? Have you ran drive diagnostic on the external?
     
  5. ZeIndieGamer

    ZeIndieGamer New Member

    Messages:
    3
    The Diagnostic basically said everything was ok and what i mean by crash report is a window that pops up when a program crashes (like for instance say i was using unity the program would be called unity crash reporter some programs don't have a crash reporter) That asks you if you would like to report the crash. (BTW replacing the internal is not an option because i'm using a laptop and thats beyond my ability.)
     
  6. johnb35

    johnb35 Administrator Staff Member

    Messages:
    41,664
    Check event viewer under windows logs then applications for any errors. Not a lot to go on here. If you can remember when it actually worked you can try doing a system restore back to that day and see what happens. Have you tried different usb ports?
     

Share This Page