Really Strange Camera and SD Card Problem

Discussion in 'Digital Cameras, Webcams and Scanners' started by Knut, Jan 7, 2014.

  1. Knut

    Knut New Member

    Messages:
    180
    Hey Guys,

    Basically I was removing a bunch of things off my SD card once I took it out of my camera. Then when I took it out of the computer and put it back in my camera (Lumix FZ 100) it said "Photos will save on the built in memory" I wanted it to save on the camera. I reformatted the card and this didn't do anything. The card works on any other camera, but not in mine (I tried on 2 other cameras). The camera can also read any other card( Tried with 2 cards)

    Whats the problem? Is the card broken? Any Ideas?

    Thanks for the Help,

    Knut
     
  2. spirit

    spirit Moderator Staff Member

    Messages:
    17,364
    If the Lumix can read other SD cards, then I'd say that the card is the problem.
     
  3. Knut

    Knut New Member

    Messages:
    180
    And the card can be read by other cameras sooo... I have no clue :)
     
  4. spirit

    spirit Moderator Staff Member

    Messages:
    17,364
    Looks like your Lumix is rejecting it for some reason. Can you do a firmware upgrade on it?
     
  5. Knut

    Knut New Member

    Messages:
    180
    Kind of a noob, do you know how you would do that, Ill look into it and try.
     
  6. Knut

    Knut New Member

    Messages:
    180
    Ok I tried the card again on a camera I have at home (A nikon camera) and it did not read aswell. It reads on my computer though (Wiered). And the firmware cant be updated anyway because its already the most updated firmware.


    EDIT: I tried the card on an older digital camera, and it worked just fine... this is so annoying.
     
    Last edited: Jan 7, 2014
  7. spirit

    spirit Moderator Staff Member

    Messages:
    17,364
    If the Lumix works with other cards and not this one I'd just use another card. Clearly something is up with this card.
     
  8. Knut

    Knut New Member

    Messages:
    180
    Sadly this is the only card that I have available to me. Crap
     
  9. Knut

    Knut New Member

    Messages:
    180
    I just noticed something new, I got the camera and the card to work by pressing the card in while taking a picture, but when it is just in normally the card is not recognised. What do I do about that?

    EDIT: Just found the tiniest of chips in the top corner of the car, perhaps this is why it wont lock into place correctly in the camera.
     
    Last edited: Jan 7, 2014
  10. Punk

    Punk Moderator Staff Member

    Messages:
    9,611
    This is definitely a problem with your card's position in your camera and yes it might be coming from a damaged chip on your card. I would suggest replacing the card as it will become a pain in the *** to take a picture while pressing on the card...

    Cards aren't expansive, what card do you have right now?

    EDIT: a 32GB SDHC card is about 30€ so 36$ dollar if you want to buy a new one.
     
  11. Knut

    Knut New Member

    Messages:
    180
    Thanks ended up buying a new card, which was very inexpensive. Thanks to everyone for the help!
     

Share This Page