Secondary HDD Keeps Disappearing while installing games on to it


New Member
Hello All

I've encountered a weird problem with my PC. Not long ago i bought a new HDD (1tb Seagate Barracuda) because I assumed my old one has died (I've had it for 6 years ish). when it arrived i slotted it in to my PC and tried to format, it wouldn't work. An error kept appearing, my initial thoughts where that it's a faulty HDD and so i send it back. When the new one arrived I've managed to format it no problem but when i tried to install a game on it, it disappeared and only after i "Scanned for Hardware Changes" in Computer Management i got it back. I decided to switch my SATA cables (with my OS containing SSD)to see if it's a faulty SATA cable, which sorted the problem for a while. I've managed to install a couple of games on it and play some. However when i tried to install another game (Rainbow Six Seigh) today it disappeared again. It does reappear normal with all the files on it if i search for it in the Computer Management. I've tried making changed in the power settings and made sure that the hard disk doesn't turn off. I have also tried switching ports around. I cannot for the life of me whats happening?

In even Viewer The messages appearing are:

"The device, \Device\Harddisk0\DR4, is not ready for access yet."

"An error was detected on device \Device\Harddisk0\DR4 during a paging operation."

"Disk 0 has been surprise removed.""The system failed to flush data to the transaction log. Corruption may occur in VolumeId: D:, DeviceName: \Device\HarddiskVolume7.

My specs are:

Motherboard- Gigabyte GA-78LMT-USB3

CPU - Processor AMD FX(tm)-6300 Six-Core Processor, 3500 Mhz, 3 Core(s), 6 Logical Processor(s)

Storage - SSD (Kingston 250MB) HDD <---The problem (Seagate Baraccuda 1TB)

Power Supply - Arctic 750W

GPU (not sure in relevant but) - ASUS GTX 970

OS - Windows 10

Thank you in advance for all the help