USB ports not working anymore

JLychar

New Member
Hello,

I come to ask for you help 'cause I don't know what to do.
I've disassembled my laptop, a HP Pavilion x360 u005-nf precisely, to access the RAM below the motherboard, in view to change it for a more consequent one, and check if the max frequency that the PC can handle was indicated. As I didn't find that information, I've reassembled my laptop, connected all the cables and started it. Everything was working, except one thing: all the ports USB weren't working anymore. The two rights and the 3.0 one left, none was working, and I tried different USB keys and dongles...
I've tried removing the battery a whole night, pressing the power button without any alimentation for few minutes, reinstalling the USB drivers ('cause the different USB devices still figure in the manager, not showing any problem), but nothing works.

I don't know what I can do more.
I hope someone could help me.
Thanks
 

porterjw

Moderator
Staff member
You possibly either missed plugging something back in properly or damaged the USB controller. Double check all the PCB to PCB connections are secure (no wires, just little areas that click into place similar to a Lego).
 
Top