Why can't I run games smoothly despite having high FPS?

Discussion in 'Computer Games and Consoles' started by Reroller1, Aug 26, 2018.

  1. Reroller1

    Reroller1 New Member

    Messages:
    3
    First of all I would like to thank you for reading this thread! I have been struggling with a problem ever since I have built this new PC and I have no idea how to fix it even though I've tried lots of things.

    The problem is that in any game that I play despite having large amounts of FPS (100+) I get stuttering, it happens in older games like Runescape/Doom or newer titles like Bioshock Infinite or World of Warcraft. The stuttering feels like the game constantly freezes for 0.1 sec when I'm moving my camera around. This experience results in a non smooth gaming experience which is really frustrating. I have to point out that what I'm seeing is def not screen tearing but a form of stuttering/micro stuttering and none of the components are overclocked!

    Because I'm struggling with this issue for such a long time I even went and bought new 2 RAM sticks, new power supply, new monitor and I even upgraded my OS from Windows 7 to Windows 10 but the issue is still there. There are only 4 components left that could be causing this: HDD, GPU, MOBO or the CPU but I have no clue how to find which one is the culprit for this problem. It could also be some sort of a setting that I need to enable/disable in order to fix this issue but again I have no clue what that settings could be.

    Would really appreciate if you guys could help me out, I have no clue what to do anymore and I am down to literally try anything you guys suggest...

    PC SPECS:
    - Asus GTX 970 STRIX 4GB OC edition
    - i5 4690k 3.5 Ghz quad core with a stock cooler
    - Z97 MSI Gaming 5
    - WD 1TB HDD
    - Samsung CFG73 144Hz 1ms
    - 2x 8GB HyperX Fury 1866 Mhz
    - Corsair CX600
     
    Last edited: Aug 26, 2018
  2. Agent Smith

    Agent Smith Well-Known Member

    Messages:
    3,324
    There is a definite common denominator here and since you changed OSs it sounds like it's hardware related. The only thing I can think of is that you have bad RAM or a bad HDD. Or perhaps there's something in the background eating the CPU. You could run task manager to find out.


    To test your RAM download Memtest 86+.

    To test your HDD try HDTune, Crystaldiskinfo and H2Testw.


    It could even be a simple setting in the game.

    In the BIOS, is the internal GPU disabled?

    http://memtest.org/

    https://www.hdtune.com/

    https://crystalmark.info/en/software/crystaldiskinfo/

    https://www.softpedia.com/get/System/System-Miscellaneous/H2testw.shtml
     
    Jushana likes this.
  3. Reroller1

    Reroller1 New Member

    Messages:
    3
    Thank you so much for responding! Tested the RAM with Memtest and the RAM sticks should be fine according to the software. Here are the results of the program scans that you recommended me to try out https://imgur.com/a/aSn6VPk I hope I did the procedure correctly.

    I thought that it was an in game setting that was causing the issue as well but after messing around with pretty much everything in the game I ruled that option out. And the thing is the issue appears in games that are 10 years old and in games that have been recently released which is really weird. For example in old school Runescape I get a crap ton of FPS but the game appears "choppy" and not smooth at all when I move my camera around. And on the other hand if you look at Bioshock I get solid 100-200 FPS but still the game micro stutters and is not butter smooth like I expected it to be. The BIOS says that the "initiate graphic adapter" is set to PEG which is think that means that the internal GPU is disabled if I'm not wrong :O ?
     
  4. Agent Smith

    Agent Smith Well-Known Member

    Messages:
    3,324
    Be sure to delete all of the .H2W files on your hard disk.

    It appears that a dedicated GPU will disable onboard automatically.

    How many passes did you use with Memtest?

    Do you have any USB peripherals attached besides mouse and keyboard?

    While you game run task manager and see if there's anything using HDD IO or CPU cycles.
     
  5. Reroller1

    Reroller1 New Member

    Messages:
    3
    After months of tinkering around with different settings and configurations I've finally found the fix which turned out to be really simple. I went to NVIDIA control panel and forced V-Sync to FAST mode and set the maximum prerendered frames to 4. Now when I boot up games they run like butter which makes me really really happy! I hate myself for trying everything else in the control panel except those 2 settings that I mentioned.... Hopefully this answer will be helpful to the people that have similar issues with their games.
     

Share This Page